NASA may have fixed the Hubble Telescope the way you fix your router

hubblenasa

There’s a reason the first step to troubleshooting technology is usually ridiculously simple: turning things on and off again often works. It shouldn’t be any surprise then, that when one of the Hubble Space Telescope’s gyroscopes stated acting up, NASA decided to try putting the faulty backup gyro through a ‘running restart.’

OK, that’s a little more complicated than turning it on and off again. The gryoscope had been turned off for over 7.5 years, and since being turned on had been returning incorrect rotation rates. NASA hoped that turning the gryo off for a single second, then restarting it before the wheel stopped spinning, might clear the fault — but it didn’t work. Instead, NASA coaxed the gyro into normal operation by switching it into ‘high mode’ and ‘low mode’ while turning the Telescope in opposite directions.

Here’s how NASA described the process, in technical terms:

In an attempt to correct the erroneously high rates produced by the backup gyro, the Hubble operations team executed a running restart of the gyro on Oct. 16. This procedure turned the gyro off for one second, and then restarted it before the wheel spun down. The intention was to clear any faults that may have occurred during startup on Oct. 6, after the gyro had been off for more than 7.5 years. However, the resulting data showed no improvement in the gyro’s performance.

hubblenasa

On Oct. 18, the Hubble operations team commanded a series of spacecraft maneuvers, or turns, in opposite directions to attempt to clear any blockage that may have caused the float to be off-center and produce the exceedingly high rates. During each maneuver, the gyro was switched from high mode to low mode to dislodge any blockage that may have accumulated around the float.

It’s true, that’s a little more complicated than my gross oversimplification — but it’s sort of fun to imagine the steps for fixing the Hubble Space Telescope aren’t that different than the steps you might take to troubleshoot your router. Turn it on and off again. Jiggle things back and forth. Play around with the settings. If you’re lucky, these seemingly meaningless actions will reset whatever was wrong and get things back on track. After all, it works for NASA.

The Hubble operations team says the problem seems to have been resolved, but it will be running additional tests to make sure before returning the telescope to normal operations.

 

Leave a Reply

Your email address will not be published. Required fields are marked *